Free shipping on all orders.
 

Sound troubleshooting

There’s no audio coming from my headphones.

Make sure the headphones are turned on

Check the condition of the audio cable. If the plug or any part of the cable has been damaged, that could be causing the problem

Be sure the headphones are connected properly. The headphones may be connected improperly or the connection may have come loose. Remove and reseat the headphone connector on both ends

Make sure the audio device is on and the volume is turned up

Try a different audio device. The problem could be with the audio device to which your headphones are currently connected

Toggle the Hi/Lo switch to ensure it is set properly. If the position of the Hi/Lo switch is in between settings it could result in no audio

Try the additional audio cable that was included with your headphones (QC®15 headphones only, purchased after June, 2011). If the issue is only specific to one cable, that cable should be replaced

I can hear audio from only one side of my headphones.

Check the balance level on the source. If the source has balance level adjustment, it may be adjusted incorrectly. Be sure it is set to a middle level

Be sure the headphones are connected properly. The headphones may be connected improperly or the connection may have come loose. Remove and reseat the headphone connector on both ends

Try the additional audio cable that was included with your headphones (QC®15 headphones only, purchased after June, 2011). If the issue is only specific to one cable, that cable should be replaced

There is too much bass in my headphones.

Turn off any audio enhancement features on the audio source

Was this helpful?

Submit

Thank you for submitting your comments.